Hier ist wieder eines der 100 Argumente warum ich zum Teil _leider_ von Debian auf Gentoo gewechselt habe. Meine Absicht war ja nur amarok zu erneuern da amarok oefter mal Probleme bereitet hat. Nur Amarok ging aber nicht, da dann kopete nicht installiert werden kann.

Aber schaut mal selber: So wie hier beschrieben gehts mir oefter:

apt-get update

root@QKliX:/home/conny# fg

apt-get update
Get:4 http://ftp.de.debian.org unstable/main Release [82B]
Get:5 http://ftp.de.debian.org unstable/non-free Packages [71.1kB]
Get:6 http://ftp.de.debian.org unstable/non-free Release [86B]
Get:7 http://ftp.de.debian.org unstable/contrib Packages [61.9kB]
Get:8 http://ftp.de.debian.org unstable/contrib Release [85B]
Get:9 http://ftp.uni-stuttgart.de unstable/main Release [82B]
Get:10 http://ftp.uni-stuttgart.de unstable/non-free Packages [71.1kB]
Get:11 http://ftp.uni-stuttgart.de unstable/non-free Release [86B]
Get:12 http://ftp.uni-stuttgart.de unstable/contrib Packages [61.9kB]
Get:13 http://ftp.uni-stuttgart.de unstable/contrib Release [85B]
Get:14 http://sunsite.informatik.rwth-aachen.de unstable/main Release [82B]
Get:15 http://sunsite.informatik.rwth-aachen.de unstable/non-free Packages  [71.1kB] 
Get:16 http://sunsite.informatik.rwth-aachen.de unstable/non-free Release [86B]
Get:17 http://sunsite.informatik.rwth-aachen.de unstable/contrib Packages [61.9kB]
Get:18 http://sunsite.informatik.rwth-aachen.de unstable/contrib Release [85B]
Fetched 12.3MB in 1m50s (111kB/s)
Reading Package Lists... Done

Wie immer eigentlich super Zuverlaessig, dafuer liebe ich Debian!

apt-get install

root@QKliX:/home/conny# apt-get install amarok
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
 akregator amarok-arts amarok-engines amarok-gstreamer amarok-xine ark artsbuilder dcoprss hspell k3b kaddressbook kaffeine
 kaffeine-gstreamer kaffeine-xine kalarm kamera kandy kappfinder karm kate kcharselect kcoloredit kcontrol kde-i18n-de
 kdebase-bin kdebase-data kdebase-kio-plugins kdegraphics-kfile-plugins kdelibs-bin kdelibs-data kdelibs4-dev kdelibs4c2a
 kdelirc kdenetwork-filesharing kdenetwork-kfile-plugins kdepasswd kdepim kdepim-kfile-plugins kdepim-kio-plugins
 kdepim-kresources kdepim-wizards kdeprint kdesktop kdessh kdf kdict kdm kdvi kedit kfax kfind kfloppy kgamma kget
 kghostview kgpg khelpcenter khexedit kicker kiconedit kig kile kitchensync kjots klaptopdaemon kleopatra klipper kmail
 kmailcvt kmenuedit kmilo kmix kmrml knewsticker knode knotes kolourpaint konqueror konqueror-nsplugins konsole
 konsolekalendar kontact kooka korganizer korn kpager kpdf kpersonalizer kpf kpilot kpovmodeler kppp krdc kregexpeditor krfb
 kruler ksim ksirc ksmserver ksnapshot ksplash kstreamripper ksvg ksync ksysguard ksysguardd ktalkd ktimer ktip ktnef
 kuickshow kuser kview kviewshell kvoctrain kwalletmanager kwifimanager kwin libacl1-dev libarts1-dev libarts1c2a libartsc0
 libartsc0-dev libasound2 libasound2-dev libattr1-dev libboost-python1.33.1 libcairo2 libdb4.3 libdbus-1-2 libdbus-qt-1-1c2
 libfribidi0 libgadu3 libglib2.0-0 libglib2.0-dev libgphoto2-2 libgphoto2-port0 libhal-storage1 libhal1 libindex0 libiw28
 libk3b2 libkadm55 libkcal2b libkdepim1a libkgantt0 libkleopatra1 libkmime2 libkonq4 libkpimexchange1 libkpimidentities1
 libkrb5-dev libkrb53 libkscan1 libksieve0 libktnef1 liblockdev1 liblua50 liblua50-dev liblualib50 liblualib50-dev
 libmimelib1c2a libmusicbrainz4c2a libmysqlclient15 libopenexr-dev libopenexr2c2a libpoppler0c2 libpoppler0c2-qt
 libreadline4 libreadline5 libreadline5-dev librss1 libsensors3 libssl0.9.8 libtag1c2a libtunepimp2c2a libvisual0.2 libxml2
 libxml2-dev libxrender-dev libxrender1 lisa lua50 mysql-common mzscheme networkstatus python2.4 python2.4-minimal
 readline-common superkaramba usbutils
Suggested packages:
 libvisual0.2-plugins ruby python-qt3 libqt0-ruby1.8 gstreamer0.8-plugins rar unrar unrar-free normalize-audio toolame sox
 movixmaker-2 kttsd kate-plugins konq-speaker kde kdepim-doc-html egroupware kicker-applets kdeedu-doc-html gbib
 pybliographer kile-i18n knewsticker-scripts konq-plugins kweather libasound2-plugins libasound2-doc libglib2.0-doc gtkam
 krb5-doc krb5-user linux-image-2.6 kernel-image-2.6 lm-sensors-mod-2.9.2 lm-sensors-mod-2.9.1 libtunepimp2-dev
 libtunepimp-bin samba-common slib python2.4-doc
Recommended packages:
 kdemultimedia-kio-plugins gstreamer0.8-flac gstreamer0.8-audiofile arj ncompress zoo hal pmount gamin rdesktop
 libio-socket-ssl-perl libarts1-akode libglib2.0-data libiodbc
The following packages will be REMOVED:
 dbus-qt-1c2 k3blibs kcalc kdelibs4c2 kdeutils kopete libarts1c2 libkleopatra0a libmimelib1c2 libmusicbrainz4c2
 libopenexr2c2 libreadline4-dev libtag1c2 libtunepimp2c2
The following NEW packages will be installed:
 hspell kdelibs4c2a libacl1-dev libarts1c2a libattr1-dev libboost-python1.33.1 libcairo2 libdb4.3 libdbus-1-2
 libdbus-qt-1-1c2 libhal-storage1 libhal1 libindex0 libk3b2 libkleopatra1 liblockdev1 liblua50 liblua50-dev liblualib50
 liblualib50-dev libmimelib1c2a libmusicbrainz4c2a libmysqlclient15 libopenexr2c2a libpoppler0c2 libpoppler0c2-qt
 libreadline5-dev libssl0.9.8 libtag1c2a libtunepimp2c2a libvisual0.2 lua50 python2.4 python2.4-minimal readline-common
 usbutils
The following packages will be upgraded:
 akregator amarok amarok-arts amarok-engines amarok-gstreamer amarok-xine ark artsbuilder dcoprss k3b kaddressbook kaffeine
 kaffeine-gstreamer kaffeine-xine kalarm kamera kandy kappfinder karm kate kcharselect kcoloredit kcontrol kde-i18n-de
 kdebase-bin kdebase-data kdebase-kio-plugins kdegraphics-kfile-plugins kdelibs-bin kdelibs-data kdelibs4-dev kdelirc
 kdenetwork-filesharing kdenetwork-kfile-plugins kdepasswd kdepim kdepim-kfile-plugins kdepim-kio-plugins kdepim-kresources
 kdepim-wizards kdeprint kdesktop kdessh kdf kdict kdm kdvi kedit kfax kfind kfloppy kgamma kget kghostview kgpg khelpcenter
 khexedit kicker kiconedit kig kile kitchensync kjots klaptopdaemon kleopatra klipper kmail kmailcvt kmenuedit kmilo kmix
 kmrml knewsticker knode knotes kolourpaint konqueror konqueror-nsplugins konsole konsolekalendar kontact kooka korganizer
 korn kpager kpdf kpersonalizer kpf kpilot kpovmodeler kppp krdc kregexpeditor krfb kruler ksim ksirc ksmserver ksnapshot
 ksplash kstreamripper ksvg ksync ksysguard ksysguardd ktalkd ktimer ktip ktnef kuickshow kuser kview kviewshell kvoctrain
 kwalletmanager kwifimanager kwin libarts1-dev libartsc0 libartsc0-dev libasound2 libasound2-dev libfribidi0 libgadu3
 libglib2.0-0 libglib2.0-dev libgphoto2-2 libgphoto2-port0 libiw28 libkadm55 libkcal2b libkdepim1a libkgantt0 libkmime2
 libkonq4 libkpimexchange1 libkpimidentities1 libkrb5-dev libkrb53 libkscan1 libksieve0 libktnef1 libopenexr-dev
 libreadline4 libreadline5 librss1 libsensors3 libxml2 libxml2-dev libxrender-dev libxrender1 lisa mysql-common mzscheme
 networkstatus superkaramba
156 upgraded, 36 newly installed, 14 to remove and 841 not upgraded.
Need to get 162MB of archives.
After unpacking 62.8MB of additional disk space will be used.
Do you want to continue? [Y/n]
root@QKliX:/home/conny# apt-get install amarok kopete
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kopete: Depends: libmeanwhile0 (>= 0.4.2) but it is not installable
E: Broken packages

Fazit

Unter Gentoo muss ich immer ewig warten bis alles Compiliert ist, aber dort arbeitet die Maschine dann zwei Tage und nicht ich!

Bei Debian ist man viel mit deinstallieren, installieren und Paketabhaengikkeiten erzwingen (--force-all z.B.) beschaeftigt.

Das sieht dann so aus:

dpkg -i foobar.deb --force-all

Einfach grausam sowas und ich hab keine Lust mehr meine Zeit an solchen Sachen zu verschwenden!

Mir gefaellt auch das unter Gentoo viele Tools "farbbige Ausgabe" verwenden. Man sieht so einfach recht schnell was los ist. Bei Debian ist halt gestern heute und darum sind so viele defaults einfach unbrauchbar bzw hinderlich.

Beim Booten unter Gentoo wird standardmaessig mit farben gearbeitet und wenn man ein neues Programm wie apache installiert muss man dieses dann selbst in das entsprechende Runlevel eintragen.

Solange Debian in diesen Punkten nicht besser wird, sehe ich keine Moeglichkeit Debian weiter zu verwenden obwohl ich die Arbeit der Packetmaintainer sonst fuer qualitativ sehr schaetze.

Powered by MediaWiki